SAML Logon is showing the error "Problem Validating the Authentication Request"
Symptom
When logging to the application with the SAML Logon, the page loads and ends on this view :
Cause
The authentication request sent by the Identity Provider is not signed.
It is not mandatory to have a signed response, but by default we enforce a "strict" mode that expects assertions to be signed.
Resolution
- Stop the 360 Tomcat service.
- Go to WebPlatform installation Directory, double click on Tomcat Configuration shortcut.
- Browse to the Java tab.
- In the Java Options field, add:
-Dwp.signature.saml=true
Do not set this option on the "Java 9 Options" field, this field must be left empty.
- Restart the 360Tomcat service.
- Try to log with SAML once again, the error message is not here anymore.
This option activates a "lax" mode that allows assertions not to be signed.